Hello Community, 

Can someone explain Web Analytics in SharePoint 2013? I have a few instances where we need it, but it is not working correctly. I realize that it is not it's own service any longer, and now a part of Search, but when viewing the Popularity Trends pages (_layouts/15/Reporting.aspx?Category=AnalyticsSiteCollection), a majority of the reports are blank and show "0" for every category. 

Has anyone been able to successfully enable Web Analytics in 2013? There isn't a whole lot out there in regards to configuration. 

According to this TechNet Article, under the Web Analytics in SharePoint Server 2010 section, it states that "SharePoint 2013 still logs every click in SharePoint sites and still provides a count of hits for every document" - where is this information found? 

That article also states that "Administrative reports for the quota usage of site collections in the farm are not available in SharePoint 2013." - so apparently there isn't a whole lot of analytical data out there for 2013. 

Just to clarify, both instances I am trying are migration from SharePoint 2010. Both versions are server. 

Any help would be greatly appreciated. 

Thanks, 

Joe

Tags: 2013, Analytics, SharePoint, Usage, Web

Views: 406

Reply to This

Replies to This Discussion

We developed a SharePoint Analytics solution for sites and portals based on SharePoint that is compatible with both 2013 and 2010 platforms: http://www.harepoint.com/Products/HarePointAnalyticsForSharePoint/Default.aspx

Hi,

The URL that was mentioned in your first paragrah should finish Category=AnalyticsSite I believe.

Not sure about configuring Web Analytics after a migration but I have setup Web Analytics in a SharePoint 2013 test environment and it seems to be OK. Although I did note that the state service was required for certain reports, do you have this setup? Sorry if you do.

The only other real configuration steps that were taken was to ensure that the Search Service was provisioned and that the Analytics Processing component was confirmed as showing OK on the Search Administration page.

The other possibilty is that a timer job that collects the necessary data for your chosen report has not run for some reason.

There is a usage data collection configuarition area in Central Administration > Monitoring - but don't think this is going to be applicable to the usage data you are after.

So once it is all up and running, you only really seem to have the Popularity Trends option under Site Administration and the Popularity and Search option under Site Collection Administration. If you wanted any more than this then it seems you have to look to a third party solution or custom develop something as the data you are after is present in the Database, just needs to be surfaced.

   

 

 

RSS

© 2014   Created by Mark Jones.   Powered by

Badges  |  Report an Issue  |  Terms of Service

Live Support